SOLR-12141: Fix "bin/solr" shell scripts (Windows/Linux/Mac) to correctly detect...
authorUwe Schindler <uschindler@apache.org>
Tue, 27 Mar 2018 20:49:23 +0000 (22:49 +0200)
committerUwe Schindler <uschindler@apache.org>
Tue, 27 Mar 2018 20:49:23 +0000 (22:49 +0200)
commitade2cf2e742fc4f2c312064df9e1ac78159bb23a
tree95db903d6d43a071be4e7f30b7ff1ea28f824efc
parent08686038e1378aca09efdc6b6657c065713fe8f2
SOLR-12141: Fix "bin/solr" shell scripts (Windows/Linux/Mac) to correctly detect major Java version and use numerical version comparison to enforce minimum requirements. Also remove obsolete "UseParNewGC" option. This allows to start Solr with Java 10 or later.
solr/CHANGES.txt
solr/bin/solr
solr/bin/solr.cmd