Fixing broken OSGi package configuration
authorNiklas Gustavsson <ngn@apache.org>
Mon, 27 Sep 2010 15:10:30 +0000 (15:10 +0000)
committerNiklas Gustavsson <ngn@apache.org>
Mon, 27 Sep 2010 15:10:30 +0000 (15:10 +0000)
git-svn-id: https://svn.apache.org/repos/asf/mina/ftpserver/branches/1.0.x@1001772 13f79535-47bb-0310-9956-ffa450edef68

core/pom.xml

index c8e062b..033e199 100644 (file)
@@ -69,6 +69,7 @@
                                                        org.apache.ftpserver.config.spring;version=${project.version},
                                                        org.apache.ftpserver.filesystem.nativefs;version=${project.version},
                                                        org.apache.ftpserver.ftpletcontainer;version=${project.version},
+                                                       org.apache.ftpserver.ipfilter;version=${project.version}, 
                                                        org.apache.ftpserver.listener;version=${project.version}, 
                                                        org.apache.ftpserver.main;version=${project.version},
                                                        org.apache.ftpserver.message;version=${project.version},
@@ -82,7 +83,9 @@
                                                        org.apache.ftpserver.impl, org.apache.ftpserver.listener.nio,
                                                        org.apache.ftpserver.message.impl, org.apache.ftpserver.ssl.impl,
                                                        org.apache.ftpserver.usermanager.impl,
-                                                       org.apache.ftpserver.util</Private-Package>
+                                                       org.apache.ftpserver.util,
+                                                       org.apache.ftpserver.*
+                                               </Private-Package>
                                                <Import-Package>
                                                        org.springframework.beans.factory.config;resolution:=optional;version="2.5",
                                                        org.springframework.beans.factory.support;resolution:=optional;version="2.5",