SAMZA-1428: Fix scala 2.10 compilation issue with java 8 interface st…
[samza.git] / bootstrap.gradle
1 /*
2  * Licensed to the Apache Software Foundation (ASF) under one
3  * or more contributor license agreements.  See the NOTICE file
4  * distributed with this work for additional information
5  * regarding copyright ownership.  The ASF licenses this file
6  * to you under the Apache License, Version 2.0 (the
7  * "License"); you may not use this file except in compliance
8  * with the License.  You may obtain a copy of the License at
9  *
10  *   http://www.apache.org/licenses/LICENSE-2.0
11  *
12  * Unless required by applicable law or agreed to in writing,
13  * software distributed under the License is distributed on an
14  * "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
15  * KIND, either express or implied.  See the License for the
16  * specific language governing permissions and limitations
17  * under the License.
18  */
19
20 /**
21  * This file allows a source release of Samza, which is prohibited
22  * from containing jars, to be able to download the gradle wrapper
23  * and its accompanying jars.
24  */
25
26 defaultTasks 'downloadWrapper'
27
28 task downloadWrapper(type: Wrapper) {
29     description = "Download the gradle wrapper and requisite files. Overwrites existing wrapper files."
30     gradleVersion = project.gradleVersion
31 }